Pictofit / Web SDK / 7.3.1 / Getting Started

Getting Started

The core of the SDK is the Java Script module file pictofit.min.js which needs to be loaded by your web site. Since our SDK is based on babylon.js, you also need to include it as well. To do this, you can directly rely on their CDN to do so or host the library yourself.

Prerequisites

  • HTML5 and WebGL
  • ES6 compatible browser

Browser Compatibility

The following browsers (and newer) have been checked for compatibility

  • Chrome 61
  • Edge 41.16299
  • Opera 55
  • Firefox 56
  • Safari 11

To check if WebGL is supported by the client, you can use https://github.com/mrdoob/three.js/blob/master/examples/jsm/WebGL.js

Example: Check WebGL availability

<script>
if ( WEBGL.isWebGLAvailable() ) {
    // init the viewer
} else {

    var warning = WEBGL.getWebGLErrorMessage();
    // inform the user that the browser doesn't support WebGL
}
</script>

The following sections explain how to set up the viewer and how to use it. Please also see our samples repository for more resources.

© 2014-2020 Reactive Reality AG